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NOTES ON VMWARE WORKSTATION 6.0, BUILD 44426 

Build 44426 is a release candidate build of VMware Workstation 6.0.  

The release notes contain the following: 

l New Support for 32-Bit and 64-Bit Operating Systems  
l New Features in This Release  
l Known Issues with This Release  

NEW SUPPORT FOR 32-BIT AND 64-BIT OPERATING SYSTEMS 

This release provides experimental support for the following operating systems: 

l 32-bit and 64-bit Red Hat Enterprise Linux 4.5 (Beta, formerly called 4.0 Update 5) and Red Hat Enterprise Linux 5.0 as host 
and guest operating systems  

l 32-bit and 64-bit SUSE Linux Enterprise Server 9 SP4 (Beta) as host and guest operating systems  
l 32-bit and 64-bit Ubuntu Linux 7.04 (Beta) as a guest operating system  

This release provides full support for the following operating systems: 

l 32-bit and 64-bit Windows Vista as host and guest operating systems  
l 32-bit and 64-bit Ubuntu Linux 6.10 as host and guest operating systems  
l 32-bit and 64-bit Mandriva Linux 2007 as host and guest operating systems  
l 32-bit and 64-bit Solaris 10 Update 3 as guest operating system  
l 32-bit Novell Netware 6.5 SP5 as guest operating system  

NEW FEATURES IN THIS RELEASE 

l Record/Replay of Virtual Machine Activity (Experimental) — This feature lets you record all of a Workstation 6 virtual 
machine’s activity over a period of time. Unlike Workstation’s movie-capture feature, the record/replay feature lets you exactly 
duplicate the operations and state of the virtual machine throughout the time of the recording. At any time during playback of a 
recording, you can click a button to "go live" from that point of execution.  

l Multiple Monitor Support — At the click of a button, the guest can now span monitors and also reflect the monitor topology — 
meaning that applications, task bars, and so on inside the guest appear as you would expect them to on a multi-monitor system. 
You can specify how many monitors a virtual machine can detect, regardless of how many monitors are attached to the host. 
This feature is especially useful if you plan to deploy the virtual machine to a different host after you create it. You can also 
specify what screen resolution to use.  

l Support for High-Speed USB 2.0 Devices   
l Easy Upgrade or Downgrade of VMware Virtual Machines — A new Change Version wizard steps you through the process 

of upgrading or downgrading virtual machines between Workstation versions 4, 5, and 6. The wizard helps you determine which 
virtual hardware version to use for various VMware products. You have the choice of either changing the version of the original 
virtual machine or creating a full clone.  

l Automation Via Expanded VIX 1.1 API — The VIX API (formerly known as the Programming API) is now compatible with 
Workstation 6. This API allows you to write scripts and programs to automate virtual machine operations. This release of the API 
is available in the C language. There are additional language bindings for Perl, COM, and shell scripts (vmrun). There is also a 
standalone installer for this API.  

l Physical-to-Virtual Conversion and Enhanced Import Functionality (Windows Hosts Only) — Included in this release is the 
Converter Import wizard from the VMware Converter product. Using this wizard enables you to convert a physical Windows 
machine into a virtual machine, convert a virtual machine from one VMware virtual machine format to another, and convert 
virtual machines or system images from popular third-party vendors.  

l Automatic Upgrade to the Latest Version of VMware Tools  — You can now set VMware Tools to automatically upgrade itself 
when a Windows or Linux virtual machine is powered on.  

l Integrated Virtual Debuggers — With the new Workstation IDE (integrated development environment) plug-ins, software 
developers are provided with menu items and toolbar buttons in Visual Studio (Windows only) or Eclipse (Windows or Linux) to 
easily develop and debug programs in virtual machines. Documentation for the virtual debuggers is now included in the 
Workstation User's Manual.  

l Appliance View for Virtual Appliances — Rather than having users see a console view for an appliance, you can now 
configure the new appliance view. It gives you a brief description of the type of server or appliance and provides a link that 
opens the browser on the guest system and connects to the correct port for the server console.  

l Run Virtual Machines in the Background — You can now leave virtual machines and teams running in the background when 
you exit Workstation. On the host, a system tray icon indicates how many virtual machines are running in the background. Click 
the icon to open a virtual machine.  

l Enhanced File Sharing and Copy and Paste Functionality — You can now use shared folders on a Solaris guest. You can 
copy and paste text and files between Linux and Windows hosts and Linux, Windows, and Solaris guests.  

l Cross-Platform Drag-and-Drop Functionality — You can now drag and drop files and directories from a Linux or Windows 
host to a Linux, Solaris, or Windows guest, and vice versa.  

l Virtual Machines Can Act as VNC Servers — You can set a virtual machine to act as a VNC server without having to install 
any specialized VNC software in the guest.  

l New Online Help System  — The help system includes full-text search, bookmarking ability, index, and table of contents.  
l Battery Information Is Now Reported in the Guest — If you use a laptop to run a guest in full screen mode, you will now be 

able to see status information about the host's battery.   
l Increased RAM Support — The previous limit of 4GB total RAM that could be used for all virtual machines combined has been 

removed. The amount of memory used by all virtual machines combined is now limited only by the amount of the host 
computer’s RAM and page file size. The maximum amount of memory that can be allocated per virtual machine has been raised 
from 3.6GB to 8GB.  

l Support for Paravirtualized Linux Kernels — If you have a VMware VMI (Virtual Machine Interface) 3.0 enabled kernel in a 
Linux guest operating system, you can now enable paravirtual support in the virtual machine.  

l User Interface for Mapping a Virtual Disk to a Drive Letter on the Windows Host  
l Improved 64-bit Guest Support — Intel EM64T VT-capable processors are now fully supported.  
l New 64-bit Sound Driver  
l Virtual Machine Communication Interface (Experimental) — VMCI (CrossTalk) provides a faster means of communication 

among applications running on the host and in virtual machines. The VMCI infrastructure comprises an SDK and drivers for host 
and guest. This experimental feature is especially suited for users who want to write client-server applications. For more 
information, see the README file. On Linux hosts, the README file is located in the 
directory /usr/share/doc/vmware/vmware-crosstalk/samples. On Windows hosts, it is in the CrossTalk  folder in 
VMware Workstation installation directory; for example, C:\Program Files\VMware\VMware Workstation\CrossTalk.  

l Enhanced virtual keyboard on Windows hosts — Now when you press Ctrl-Alt-Delete, the Windows guest system only, 
rather than both guest and host, will act on the command. The new virtual keyboard provides better handling of international 
keyboards and keyboards with extra keys. This feature also offers security improvements, as it processes raw keyboard input as 
soon as possible, bypassing Windows keystroke processing and any malware that’s not already at a lower layer. This feature is 
currently available for all 32-bit Windows guests except Windows Vista guests.  
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l VMware Player 2.0 — The new Player Welcome page gives you the option of browsing to a virtual machine file or downloading 
a virtual appliance from the Virtual Appliance Marketplace at vam.vmware.com. You can then use Player’s new appliance view 
when running a virtual appliance. A beta version of VMware Player 2.0 can now be downloaded and installed separately from 
Workstation. For more information about the standalone VMware Player, see the VMware Player 2.0 Beta Release Notes.  

KNOWN ISSUES WITH THIS RELEASE 
l Core Application  
l Eclipse Integrated Virtual Debugger  
l Visual Studio Integrated Virtual Debugger  

Core Application 
 
l When you install Workstation on a Windows Vista host, be sure to enter the serial number at installation time. This is 

necessary so that when you enter the serial number, you will have the required permission settings. If you enter the serial 
number later, as a different user, you might not have the correct permissions.  
 

l If you run the Workstation installer on a Windows Vista host in order to use the Change option, you need to first turn 
off UAC (user access control). Otherwise, the wizard immediately displays the Finish dialog box and you receive an error 
message. 
 

l On Windows Vista hosts, if you uninstall Workstation from the Control Panel, you might see a UAC (user access 
control) prompt that warns you about an unidentified program wanting to access your computer. You can safely click 
Allow. 
 

l On Windows Vista hosts, if you start Workstation without administrative privileges, power on a virtual machine, exit 
Workstation with the virtual machine running in the background, and then start Workstation with administrative 
privileges, you cannot access the virtual machine.  
Workaround: Either always run Workstation with administrative privileges or always without. 
 

l On Windows Vista hosts, you might not be able to view or select physical disk partitions when creating a virtual 
machine. Whether you encounter this issue depends on the size and layout of the hard disk. 
 

l On Windows Vista hosts, you need to run the Virtual Network Editor as an Administrator. You need to be logged in as a 
member of the Administrators group and either disable UAC (user account control) or start the Virtual Network Editor by right-
clicking it in the Start menu and choosing Run as Administrator.  
 

l On 32-bit Windows Vista guests and Windows 2003 Server guests, if an Internet connection is not available at the time 
when the operating system is installed, the multimedia audio controller is not installed.  
Workaround: If the Windows device manager lists an unsupported multimedia audio controller, configure networking and run 
Windows Update to install the required driver. 
 

l On Windows Vista guests, to open the VMware Tools control panel, you need to be logged in as an Administrator user. 
 

l Automatic upgrades of VMware Tools might fail if the older version of VMware Tools was installed with a pre-release 
version of Workstation 6 (beta 2, beta 3, RC 1).  
Workarounds: First, try doing a manual upgrade. If the manual upgrade fails, uninstall VMware Tools from the guest. (For 
example, on Windows guests, go to Start > Control Panel > Add or Remove Programs, and remove the VMware Tools program). 
Next, reinstall VMware Tools. 
 

l For Windows 95 virtual machines created with Workstation 4.5 or ACE 1.0, upgrades of VMware Tools are sometimes 
incomplete. 
Workaround: Uninstall VMware Tools and then use Workstation 6 to install VMware Tools again. 
 

l If you install Workstation on a Windows 2003 Server host, Workstation help does not display correctly until you enable 
JavaScript. This is because, on Windows 2003 Server, JavaScript is disabled by default in Internet Explorer. 
Workaround: In Internet Explorer, choose Tools > Options > Internet > Custom Level > Scripting > Active Scripting, and choose 
Enable. 
 

l Avoid attempting to exit Workstation and run a virtual machine in the background while recording activity on that 
virtual machine, using the record/replay feature.  Doing so might cause the virtual machine to crash. Always stop recording 
before sending a virtual machine to run in the background. 
 

l If you created recordings of virtual machine activity using a previous beta or RC build, delete those recordings and do 
not attempt to use them in this RC 2 version of Workstation. On Linux hosts, doing so might cause Workstation to exit 
unexpectedly. 
 

l Pressing the middle button on a Thinkpad T43 causes the cursor to be released from guest operating systems. The 
middle button of the three buttons above the track pad is usually configured to allow scrolling. In guest operating systems, it 
does not allow scrolling and in fact causes input to be ungrabbed from the guest.  
 

l Sometimes when the virtual floppy drive is connected to the physical floppy drive on the host, the guest does not 
recognize floppy disk changes. This has been observed on both 32 bit and 64 bit Windows. 
Workaround: Connect the virtual floppy drive to the physical floppy drive while a floppy disk is in the physical drive. 
 

l On Mandrake 10.0 guests, dragging and dropping files from guest to host does not work. 
 

l If you share a folder between a Linux host and a Windows guest, symbolic links will not be accessible by the Windows 
guest. Symbolic links appear as regular files on Windows guests, but the links are not followed when you attempt to open them.  
 

l On a 64-bit Ubuntu 6.04 host and a Windows guest, you might not be able to see a shared folder on the guest.  
Workaround: On the guest, use the Add/Remove Programs item to remove VMware Tools and then install VMware Tools 
again.  
 

l If you choose File > Import to convert a Windows 2000 SP0 physical computer to a virtual machine and if the IP address 
of the DNS server or WINS server has a '0' octet, you will not be able to specify DNS and WINS information. This is due 
to a WMI bug. For more information, see the MSFT knowledge base article at: http://support.microsoft.com/kb/272617/en-us. 
 

l On hosts that use a Windows 2000 Professional SP4 operating system, occasionally, you won't be able to use File > 
Import to create a virtual machine from a physical machine. The following error message appears: Unable to determine 
guest operating system. This error occurs when the msdos.sys  file is either not present or not accessible.  
 

l The File > Open and File > Import commands have several limitations for StorageCraft ShadowStore images (.spi files) 
and Symantec Backup Exec System Recovery images (.sv2i files). The limitations are: 

1. No support for dynamic disks.  
2. Images relating to the backup of the same machine should be in the same folder, with no other images placed there.  
3. All the volumes in the disk up to the active and system volumes must be backed up. (For example, say there are 4 

partitions (1-4) on a disk, and partition 2 is the active volume and partition 3 is the system volume. Volumes 1-3 must be 
backed up.)  

4. If it is an incremental image, up to 16 incremental backups are supported.  
In addition, for StorageCraft images, there is no support for systems with logical drives if the logical drive is also a system/active 
volume. 
 

l If you use File > Import and specify that you want VMware Tools installed on the destination virtual machine, then when 
you power on the virtual machine, VMware Tools is installed and the guest operating system is rebooted without 
prompting for permission. 
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Eclipse Integrated Virtual Debugger  
 
l If you are not running the current version of VMware Tools on the guest system, when the Eclipse Integrated Virtual 

Debugger attempts to debug in a virtual machine, the message One of the parameters was invalid may appear 
in the Eclipse error log. 
Workaround: Upgrade VMware Tools to the current version on your guest systems.  
 

 

Visual Studio Integrated Virtual Debugger  
 
l Visual Studio 2005 allows multiple projects to be debugged simultaneously when Start is chosen. However, the Visual 

Studio Integrated Virtual Debugger currently supports only one project and one configuration for debugging at any 
given time. If you select multiple projects as debugging targets, the Visual Studio Integrated Virtual Debugger only chooses the 
first one on the list.  
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